ServiceChannel Regularly Scheduled Maintenance for EU
Completed
The scheduled maintenance has been completed.
Posted Nov 10, 2024 - 05:00 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 10, 2024 - 01:00 UTC
Scheduled
On Sunday, 10th Nov 2024, beginning at 1:00 AM UTC, we will perform regularly scheduled maintenance on the ServiceChannel system. During this window you may experience sporadic interruptions, including to the IVR system. We expect the entire process to last less than 1 hour, but it may take up to 4 hours.
Posted Oct 25, 2024 - 15:02 UTC
This scheduled maintenance affected: API (Authentication, Universal Connector, SFTP, SendXML, API Response), Provider Automation (Fixxbook, Login, Work Order Manager, Proposal Manager, Invoice Manager), Analytics (Analytics Dashboard, Data Direct, Analitics Download), Service Automation (Login, Dashboard, Work Order Manger, Proposal Manager, Invoice Manager, Asset Manager, Compliance Manager, Supply Manager, Project Tracker, Inventory Manager, Location List, Maps, Weather), Third Party Components (Twilio REST API, Avalara Tax Calculation Service, Rackspace - Inbound Email, Zendesk), Service Center (Phone - Inbound, Phone - Outbound, Email - servicechannel.eu, Email - servicechannel.net), Mobile Applications (SC Mobile, SC Provider), and WorkForce.